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Get a Taste of ActionScript 3.0 Hands On!

Module 1: Overview of Flash ActionScript

This module will explain what ActionScript 3.0 is, what it does and the benefit 
of using it to add functionality to your eLearning projects.

Module 2: Button Controls

During this module, we will be creating a very simple movie. You will utilize 
buttons and ActionScript to create simple navigation.

Module 3: Frame Navigation

Now that you can navigate, this module shows you how to create a simple 
frame counter that displays the total number of frames in the project, and what 
frame the user is at in the project.
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teaches Dreamweaver, Fireworks, Flash, Photoshop, and InDesign at local area 
training centers, bringing his students real-world knowledge and experience 
on how to use these products.

Thomas is the author of the book Technology for Trainers, published by ASTD 
in April 2003. Technology for Trainers is an eLearning primer, written for the 
Learning and Development professional who is faced with the task of developing 
eLearning for their organization. He is also a contributing author to the ASTD 
Handbook for for Workplace Learning Professionals, published in 2007. 
  
Thomas has his B.A. in Human Communication, his M.A. Ed with a focus on 
Educational Technology, and belongs to several professional organizations such 
as ASTD, the American Marketing Association,  eLearning Guild, Toastmasters 
and the HTML Writers Guild. Thomas is also a published and performing 
magician, a trained chef and musician.
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Module 1: Overview of Flash ActionScript
When Flash first appeared on the scene, it did an amazing job of creating 
animated objects in the browser. Moving objects, fading text and simple 
animation amazed and fascinated the web audience who were once content 
with just animated GIFs. With Flash, it was possible to create many simple, yet 
engaging, animations.

As Flash grew up, users wanted to do more things with their Flash movies. 
Developers were not content with the simple programming tools and demanded 
a more robust programming language. When Flash 5 was released, ActionScript 
1.0 was born. “Actions” was replaced by ActionScript, and a whole new level 
of interactivity became available to the Flash programmer.

With the release of Flash MX 2004, ActionScript grew up and became ActionScript 
2.0. From 2003 - 2006, users received a whole new slew of functions and 
capabilities. ActionScript was close to becoming a fully functional scripting/
programming language! It was a very exciting time, because programmers could 
create true user interactivity from within their Flash projects.

In June of 2006, ActionScript 2.0 was replaced with ActionScript 3.0 in the 
Flash CS3. ActionScript 3.0 is a completely different language. Following the 
playbook for JavaScript, ActionScript 3.0 is a complete re-write. Users who 
mastered AS 2.0 were quick to realize that they had to un-do most of what they 
already knew. Common behaviors and programming strategies went out the 
window as programmers had to re-learn many of the most common ActionScript 
behaviors and functions. 

This puts YOU into an amazing position. If you are not a master of AS 2.0, you 
can pick up AS 3.0 pretty quickly. You won’t have to “unlearn” anything. If you 
have spent lots of time mastering AS 2.0, that’s OK too! You can take what 
you already know about Flash’s power and interactivity and apply it using the 
new language.  
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Why Use ActionScript

Quite simply, ActionScript makes you movies come alive! For the eLearning 
developer, Flash is a powerful tool for the delivery of online learning. Complex 
simulations or animations that used to take weeks and months to create can 
now be completed in a very short time. Not only that, but the simulations can 
be created as interactive elements that enabled users to effect and change the 
animation.

If you are a Flash developer who creates eLearning projects, the knowledge of 
how to create simple, linear animations is no longer enough. Interactive elements 
are key to a successful eLearning project, and these interactive elements are 
programmed into Flash by using its native language: ActionScript.

Buttons, page turns, drag and drops and other sorts of interactivity, including 
database and XML connectivity, can be programmed into Flash movies using 
ActionScript.

Who’s Afraid to Code?

Does working in code scare you? That’s OK...it scares me too! As designers, 
we are used to creating pretty interfaces, graphic design work and thinking 
about the user experience. The “under the hood” programming can be very 
intimidating to people who don’t do it on a regular basis. However, if you want 
to create amazing online learning projects, you need to know some of the basics 
in order to really take your projects to the next level.

I have one regret about ActionScript in Flash : I wish I had started programming 
in ActionScript sooner than I did. I was afraid of it and only knew the bare bones 
- simple Stop or Play commands that allowed me to “fake it” for many years. 
When I finally bit the bullet and learned to program ActionScript, it took a long 
time for me to get comfortable with it. I wish I had started earlier. 

Congratulations to you for being here and stretching into this world of 
programming! I promise to make it fun and interesting!
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Actions Panel
The Actions panel is where you will be typing your code into Flash. All of the 
code you attach to the timeline will be entered into this area. In ActionScript 3.0, 
you cannot add ActionScript directly onto buttons or movie clips, everything is 
coded directly into a key frame on the timeline.  

1. 	 Actions Toolbox
	 The Actions Toolbox provides a list of all the ActionScript functionality 

in Flash. Clicking on one of the arrowed “books” opens that folder to 
reveal more books or samples of code. Double clicking on the circle next 
to the code inserts that code into the Script Pane.

2.	 Script Navigator
	 The Script Navigator shows you which frames have scripts, and allows 

you to quickly jump to the code. ActionScript is notoriously hard to edit 
and update if you are not the primary coder. The Script Navigator helps 
tremendously. 

3. 	 Script Pane
	 The Script Pane is where you will be typing your code. 

1
3

2
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House Rules

During this session, I don’t expect you to know what every panel or tool can 
accomplish. I don’t expect you to be able to understand the back story or the 
“whys” of the code. My goal is to give you a test drive of ActionScript 3.0 and 
introduce you to some of the features an eLearning developer needs to be 
successful.  I will hand hold you through most of it, so don’t worry.

Don’t be discouraged if you cannot find a tool or panel set right away. Watch my 
screen or ask your neighbor for assistance. This isn’t rocket science. No one is 
going to lose their life because you cannot immediately find the Text tool. What 
I am saying to you is to have fun with this program! Flash is very cool!

Now...Onto the Programming!!



Thomas Toth	 �
01/09

Get a Taste of ActionScript 3.0 Hands On!

Module 2: Button Controls
You are going to be creating a movie that demonstrates some of the basic 
ActionScript functions in Flash. During this module, we are going to build a 
simple menu of buttons and then add some ActionScript to make the buttons 
jump the user around the timeline. 

Before you begin any project, you have to have a good idea of what you want 
to see happen; almost like a story board. For our example, this is the sample 
“pseudo-code”:

1. 	 Four buttons on the navigation take the user to different locations on the 
timeline.

2.	 The “Home” button takes the user to the Home frame.
3.	 The “Module 1” button takes the user to the Module 1 frame.
4.	 The “Module 2” button takes the user to the Module 2 frame.
5.	 The “Test” button takes the user to the Test frame.

The first thing we are going to do is prepare the stage for our objects. We are 
going to add frame layers to house our individual elements. For our movie, we 
are going to need four layers. 

When we are done with this section, your layers will be stacked like this:

Actions
Labels
Navigation
Menu

Let’s create a new ActionScript 3.0 movie and get started. 

1.	 Open Flash CS4.

2. 	 From the main red section, choose Flash File (ActionScript 3.0) from the 
center section titled Create New.

This will open a new Flash file using the AS 3.0 virtual machine. 
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Action 1: Adding Your Layers

When you first opened your Flash movie, you had 
just one layer called Layer 1. We are going to give 
your movie three more layers.

To Add A Layer:

1.	 On the layer panel, toward the bottom of the 
stack, click on the left icon.  This is the add 
layer icon. 

2.	 A new layer titled Layer 2 will now display 
above Layer 1. 

3. 	 Click two more times until you have four 
layers.

Action 2: Changing the Titles of Your Layers

Layer 1 is not a good description of what is contained on your layer. After all, 
you may be creating movies that contain 25 or more layers. You need a way to 
understand what is contained on that layer. Flash allows you to assign a name 
to each layer in order to make them easier for you to know what is happening 
on each layer.

To Change the Title of Your Layer:

1. 	 Double click on the current layer title.

2.	 It will change to a text box and allow you to type in a new name. Press 
[Enter] when done.

3.	 Change the names of your layers to Actions, Labels, Navigation and 
Menu, top to bottom. (Refer to the image at the top of this page).
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Action 4: Locking Layers

1. 	 Click on the lock icon at the top of the layer stack. This will lock down 
all the layers in our movie. Doing so makes 
sure that we are adding content to the right 
layer.

2. 	 Unlock the Menu layer by clicking on the 
lock icon on that Layer. (Not the one at the 
top of the stack). This will unlock the Menu 
layer, allowing us to add content.

Action 5: Adding Buttons

1. 	 Click on the first frame on the Title layer.

2. 	 Open the Components Panel. Choose 
Window -> Components. 

Actions on Top

A best practice to do is to keep all your ActionScript in your top most layer 
and name that layer “Actions” or “Scripts”. By default, when you compile the 
Flash movie, it is set as “bottom-up” for the load order. This means that the 
lower-most layer is loaded first and then proceeds up to the top of the stack. 
By having your ActionScript at the top, you can be assured that all your assets 
will have loaded before your scripts try to access them.

Also, having all your scripts on a single layer makes it easier to find your scripts 
when it is time to edit!

Action 3: Saving the File

Now would be a good time to save the Flash movie. Click on File -> Save. 
Choose a name and location for your file and click [Save]. Save it to the desktop 
using your first name as the filename.

This version of Flash is the most stable, but I’d hate for you to have to start 
over!
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3. 	 The Components Panel will display. In 
ActionScript 3.0, you only have a few 
component categories to choose from. 

4. 	 Click on the gray triangle to expand the User 
Interface options.

5.	 Find the Button object. Click and drag one 
to the stage. Be sure to add them to the 
Menu layer. 

6. 	 Drag three more Button objects to the stage. 
Align them and position them where you’d 
like. 

7.	 Once you have the buttons where you’d like 
them, open the Component Inspector. Click on Window -> Component 
Inspector. 

8.	 Click on the top 
button. 

9.	 The 
Component  
Inspector 
will change, 
allowing you 
to change the 
text label that 
appears on 
your button.

10.	 With the 
top button 
selected, 
click into the 
label field 
and change 
its value to 
“Home”. 
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11.	 Click on the second button. In the Component Inspector, click into the 
label field and change its value to Module 2.

12.	 Click on the third button. In the Component Inspector, click into the 
label field and change its value to Test. 

13.	 Lock this layer. You have created your simple navigation.

14.	 Save your file. 

Action 6: Adding Frames and Labels

1.	 Using the scroll bar beneath the timeline, scroll to the right until you see 
frame 40 displayed.

2.	 Click into frame 40 of the Actions (top) layer. 

3.	 Hold down the [Shift] key and click into frame 40 of the Menu (bottom) 
layer.

4.	 You will now have a black bar filling frame 40 on all four layers. Press 
[F5]. 

5.	 By pressing [F5], you have added the necessary frames to your movie.

6. 	 Unlock the Labels layer. Click on frame 1 of the Labels layer. 

7.	 In the Properties Inspector (on the 
right), locate the Label section of 
the panel. In the Name field, type:

	 home

8.	 You will notice that the key frame 
in frame 1 of the Timeline displays 
“home”.

9.	 Click on the Text Tool, and then onto the top section of the stage. Type 
“Welcome to my eLearning project.” Click on the Selection (Black Arrow) 
tool. 
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10.	 Click into frame 10 of the Labels layer.

11.	 Right mouse click and choose Insert Keyframe. 

12.	 In the Properties Inspector, in the Labels panel, type 
	
	 module1

	 into the Name field. 

13.	 Click on the text tool.

14.	 Click into the text box and change the text to read Module 1. Click on 
the Selection (Black Arrow) tool. 

15.	 Click into frame 20 of the Labels layer.

16.	 Right mouse click and choose Insert Keyframe. 

17.	 In the Properties Inspector, in the Labels panel, type 
	
	 module2

	 into the Name field. 

18.	 Click on the text tool.

19.	 Click into the text box and change the text to read Module 2. Click on 
the Selection (Black Arrow) tool. 

20.	 Click into frame 20 of the Labels layer.

21.	 Right mouse click and choose Insert Keyframe. 

22.	 In the Properties Inspector, in the Labels panel, type 
	
	 test 

	 into the Name field. 

23.	 Click on the text tool.

19.	 Click into the text box and change the text to read Test. Click on the 
Selection (Black Arrow) tool. 
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Action 7: Naming Buttons

1.	 Each button needs to have a unique name so that when we add 
ActionScript to the project, the code knows how to process the 
interaction. 

2.	 Lock the Labels layer. 

3.	 Unlock the Menu layer. 

4.	 Click on the top button (Home). 

5.	 In the Properties Inspector, change the Instance Name to: 

	 but_home

6.	 Click on the second button.

7.	 In the Properties Inspector, change the Instance Name to:

	 but_module1

8.	 Click on the third button.

9.	 In the Properties Inspector, change the Instance Name to:

	 but_module2

10.	 Click on the bottom button.

11.	 In the Properties Inspector, change the Instance Name to:

	 but_test

12.	 Note that there are no spaces allowed in ActionScript 3.0. If you want a 
space, use _ or change capitalization techniques like:

	 butTest
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Action 8: Write ActionScript to Control the Buttons

1.	 Each button needs to have a unique name so that when we add 
ActionScript to the project, the code knows how to process the 
interaction. 

2.	 Lock the Menu layer. 

3.	 Unlock the Actions layer. 

4.	 Click on frame 1 of the Actions layer.

We need to add a listener to each of our buttons in order to “do something” when 
it is clicked. Listeners are a basic means for handling events in object-oriented 
languages. A listener is an object that is notified when an event occurs. 

To create a listener, the object on which an event will occur (such as an instance 
of a Button in our project) needs to be notified about which object will respond 
to its events. This is known as adding a listener to an object.

5.	 Open the Actions Panel. Press [F9] or choose Window -> Actions.

6.	 In the Script Pane, type:

	 but_home.addEventListener(MouseEvent.CLICK, onHome);

7.	 This sets up Flash CS4 to be “listening” for a mouse click on the but_
home instance and then execute a function named onHome. Nothing will 
happen yet (we haven’t written the functions), but we are telling Flash 
to notice any mouse clicks on the but_home instance and then execute 
the onHome function.

	 Lets add three more Event Listeners, one for each of the remaining 
buttons.

	 In the Actions panel, type:

	 but_module1.addEventListener(MouseEvent.CLICK, 
onMod1);

	 but_module2.addEventListener(MouseEvent.CLICK, 
onMod2);

	 but_test.addEventListener(MouseEvent.CLICK, onTest);
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8.	 Now that we have ActionScript listening for clicks, let’s add the function 
code to respond to each of these clicks.

9.	 In the Actions panel, press [Enter] twice to add some space between the 
listeners and the function code you are about to write. 

10. 	 On line 6 of the Actions panel, type:

	 function onHome(event:MouseEvent):void
	 	 {
	 	 	 gotoAndStop(“home”);
	 	 }
	
	 function onMod1(event:MouseEvent):void
	 	 {
	 	 	 gotoAndStop(“module1”);
	 	 }
	
	 function onMod2(event:MouseEvent):void
	 	 {
	 	 	 gotoAndStop(“module2”);
	 	 }
	
	 function onTest(event:MouseEvent):void
	 	 {
	 	 	 gotoAndStop(“test”);
	 	 }

11.	 Be sure the frame label (“home”) in the ActionScript is typed exactly the 
same as the frame label you put into each frame. “Home” or “HOME” is 
not the same as “home”.

12.	 At the bottom of your code stack, type:

	 stop();

	 This will keep your file stopped at the first frame. 

12.	 Save your file.

13.	 Test your movie. Click Control -> Test Movie.

14.	 When you click on each button, it jumps to and then stops at the labeled 
frame.
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Module 3: Frame Navigation
Now that we have the main buttons working correctly, lets add some interactivity 
that allows the user to navigate from frame to frame and show them a page 
counter. Let’s do it all in ActionScript!

Action 1: Create the Navigation Shell

1.	 Lock the Actions layer of your movie.

2.	 Unlock the Navigation layer.

3.	 Click on Frame 1 of the Navigation layer.

4.	 Click on the text tool. 

5.	 Click into the stage and type:

	 Page        of 

	 Be sure to leave space between “Page” and “of”.

6.	 Click on Window -> Common Libraries -> Buttons to open the Buttons 
panel.  
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7.	 Scroll down until you find the folder called Classic Buttons. Click on the 
folder to open it.

8.	 Inside the Classic Buttons folder, locate and open the folder called Circle 
Buttons. Drag an instance of circle button-next onto the stage. Position 
it to the right of the “page” text.

9.	 Drag an instance of the circle button-previous onto the stage. Position 
it to the left of the “page” text.

10.	 Click on the circle button-next instance and in the Properties Inspector, 
change the instance name to:

	 but_next

11.	 Click on the circle button-previous and in the Properties Inspector, change 
the instance name to:

	 but_back

12.	 Close the Classic Buttons panel.

13.	 Click on the Text tool.  In the Properties Inspector, change the drop down 
from Static Text to Dynamic Text. We are going to auto-populate text 
into a Dynamic Text box.

14.	 With the Text tool draw a square dynamic text box on the stage. Position 
it between the “page” and “of” text.
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15.	 Using the selection tool (black arrow), click on the dynamic text box. In 
the Properties Inspector, change the instance name to: 

	 myLocation 

16.	 With the text tool, draw a second dynamic text box behind the “of” 
text.

16.	 Using the selection tool, click on the second dynamic text box. In the 
Properties Inspector, change the instance name to:

	 myTotalPages

17.	 You are all set! The dynamic text boxes will be populated with variables 
so all we need to do is add the code!

Action 2: Create the Navigation Code
1.	 Lock the Navigation layer in your movie.

2.	 Unlock the Actions layer. Click onto frame 1 of the Actions layer.

3.	 Open the Actions panel (if it isn’t already opened).

4.	 Place your cursor at the start of code line 1, (in front of the button code 
currently there).

5. 	 Press [Enter] a few times to give yourself some room to add additional 
code.

6.	 Type the following code into the Actions Pane:

	 var frames:Number;
	 var totals:Number;
	 frames=currentFrame;
	 totals=totalFrames;
	 myLocation.text=(String(frames));
	 myTotalPages.text=(String(totals));

	 The first two lines set the variables frames and totals to be recognized 
as a number.
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	 We then use the global variables currentFrame and totalFrame and assign 
then to our variables of frames and totals.

	 In order for the dynamic text boxes to display the numbers, we have to 
convert them to Strings. The last two lines do this for us.

 
7.	 Now that we have the dynamic text boxes working, let’s program the 

buttons.

8.	 Let’s first create the listener code for the two buttons. At the bottom of the 
listener code stack, add the following two new lines of ActionScript.

	 but_next.addEventListener(MouseEvent.CLICK, goNext);
	 but_back.addEventListener(MouseEvent.CLICK, goBack);

9.	 Next, we will add the functions goNext and goBack to react when the 
buttons are clicked. At the bottom of the function stack, add the following 
functions.

	 function goNext(event:MouseEvent):void {
	 	 nextFrame();
	 	 frames=currentFrame;
	 	 myLocation.text=(String(frames));
	 }

	 function goBack(event:MouseEvent):void {
	 	 prevFrame();
	 	 frames=currentFrame;
	 	 myLocation.text=(String(frames));
	 }	

10.	 Save your movie. 

11.	 Test your movie. Your bottom button navigation should work as 
expected.
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Action 3: Bug Fix
1.	 When you tested your movie, did you notice that when you clicked on the 

large buttons, the page numbers got messed up. When clicking on the 
major module navigation, Flash couldn’t figure out which page number 
to display. Let’s fix that.

2.	 On the Actions layer, right mouse click on frame 10 and insert a 
keyframe. 

3.	 Add the following code to the keyframe in frame 10 of the Actions 
layer:

	 frames=currentFrame;
	 myLocation.text=(String(frames));

4.	 Now, when the user interacts with the large module buttons and jumps 
down the timeline, the myLocation dynamic text box updates with the 
current frame number.

5.	 Let’s repeat that for frames 20 and 30.

6.	 On the Actions layer, right mouse click on frame 20 and insert a 
keyframe. 

7.	 Add the following code to the keyframe in frame 20 of the Actions 
layer:

	 frames=currentFrame;
	 myLocation.text=(String(frames));	

8.	 On the Actions layer, right mouse click on frame 30 and insert a 
keyframe. 

9.	 Add the following code to the keyframe in frame 30 of the Actions 
layer:

	 frames=currentFrame;
	 myLocation.text=(String(frames));

10.	 Save and test your movie. Your navigation now works as expected!

11.	 Congratulations! You have programmed a functional interface in 
ActionScript 3.0!
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Summary
Flash is a great tool for eLearning, and utilizing ActionScript makes it a powerful 
tool to add interactivity. Don’t be afraid of the code. As you discovered in this 
session, ActionScript is a logical language. You need to be able to utilize pseudo-
code as a starting point, then figure out the ActionScript you need to make it 
all work. Several resources are listed below to help you in your development.

Recommended Web Sites and Reading

Flashkit
A fantastic web site dedicated to all things Flash. If you want to start learning 
Flash, or just want to download and use some animations in your sites, this is 
the place on the web for Flash stuff. 
http://www.flashkit.com

Friends of Ed
Friends of Ed is a publishing group out of the UK that has a fantastic set of books 
on Flash, from version MX to the current version CS4. They are a “developer to 
developer” group of authors that really give you good, usable information on the 
product. I recommend starting with the Flash CS4 for Designers and then move 
through their ranks of books. They cover everything from Basic ActionScript to 
advanced database interactivity. 

You can find their stuff on-line or wherever you buy your computer books. 
http://www.friendsofed.com

Adobe Web Site
Macromedia has a very good web site that can give you more information 
about Flash. You can also download a fully functional version of Flash CS4 to 
try for 30 days. It is the perfect way to immerse yourself in the product before 
deciding to spend the money to purchase it.
http://www.adobe.com

Peach Pit Press
Peach Pit Press has a large number of Visual Quick Start Guides on all things 
computer, and the two Flash Quick Start Guides are really good (and cheap!)
http://www.peachpit.com


